Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

assembler cooperative mode cant get it to work.

Discussion in 'Survival' started by merak, Jan 15, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. merak Apprentice Engineer

    Messages:
    149
    i Think i am doing something wrong ? if you see these pics you can see that "Ship assembler 1" is the "master" and "Ship assembler 2" is the "Slave" should this not be working?

    i just watched the patch that stated how this should be done but i cant get number 2 to start working (on the same system with conveyors and tube (big one dont remember the names :) ) what could i be doing wrong

    (singelplayer survivial: older save made a week Before Procedural asteroids)



    [​IMG] [​IMG]
     
  2. Devon_v Senior Engineer

    Messages:
    1,602
    Go to the Info tab and make sure you own both assemblers. When things don't work it's often because you somehow don't own one of them.
     
  3. DivineWrath Junior Engineer

    Messages:
    531
    Are they on the same conveyer network? I found that assemblers on different conveyer networks don't ever cooperate.

    I also found that in some cases, coop assemblers won't work together. I found that in one of my setups, I have found that assemblers seem to somehow been broken into 3 groups. Assembers in these different groups won't work with each other, so I have to set a master to each of them. I also have to set 3 build queues, otherwise 2/3rds of my production will remain idle.

    I should probably try to report this as a bug. I'm going to do some testing now.
     
  4. merak Apprentice Engineer

    Messages:
    149
    just checked i own both assemblers and it is connected to the same network, when i load a much older save and create a new assembler system then switch to survivial all works hard to pinpoint what goes wrong.. can see to it to upload my save if anyone want to try it. (only one mode but not used it yet (the one with letters)

    (rar file)

    https://uxwvtw-sn3301.files.1drv.com/y2pU4bIdMYG3nY0-J0fCzpvlf4oShfjOytofSFLezhuuhgedKWUHIalilqZqwuApR1qIvIPNW9RbSlxcbH8S8BQd9XfB9bqH8-pqfShvQGZ5OfU602UZdOP4xZFoDCz8RGSqnX04KmSMzbdRJx9wlnN1Q/Lone%20Survivor%202014-09-27%201350.rar?download&psid=1


    direct download from my OneDrive
     
    Last edited by a moderator: Jan 17, 2015
  5. Cassey Apprentice Engineer

    Messages:
    309
    Cooperative mode is sensitive to the restriction of being "in the same line". My mining platform has over 100 assemblers in 1 line, but it took me awhile to figure that out. Basically, each assembler must be either directly connected to the other, or connected via tubing, WITHOUT anything else intervening - like a cargo container or even a conveyer belt (the last surprised me).

    At least that has been my experience.
    Obviously watch your layout when you place them - end to end is easiest since that always works, but opening to opening does as well.
     
    • Like Like x 1
  6. DivineWrath Junior Engineer

    Messages:
    531
    I've been getting mixed results on my tests.

    On one platform, I had a simple conveyer network. However, I could place assemblers and they would work. I wasn't trying to break limits, merely trying to replicate a build that once worked. Mind you, the assemblers were being placed side by side, with most lines of assemblers being no more than lines of 2. I did try longer lines with different orientations of assemblers (but none being 10 or more). I was able to get over 30 assemblers to work together in that build. It wasn't a neat build, but it worked.

    However, things broke down when I deleted the assemblers, saved and reloaded, and started over by making 3 lines of 10 assemblers. The assemblers in the lines worked together, but the different lines did not.

    I made another platform, also made 3 lines of 10 assemblers, and it had the same results.
     
    Last edited by a moderator: Jan 18, 2015
  7. nobodx Senior Engineer

    Messages:
    1,027
    They seam to work when all are set to "use by everyone"
     
  8. merak Apprentice Engineer

    Messages:
    149
    yes when i change it to share with all it does work. it seem, like a bug then ?
     
  9. gimmilfactory Junior Engineer

    Messages:
    523
    I am bumping this bug forum. It has not worked for me in over 4 weeks, and I have to set all assemblers to "share with all", in order to get them to cooperate with one another. I made sure I own them all..
     
  10. Kielm Junior Engineer

    Messages:
    508
    The only time I can get assemblers to work cooperatively is when they are directly adjacent to one another.

    No tubes or conveyers in between, just stack them next to or on top of each other and it works, as long as hatches are facing each other.

    Last time I tried cooperative mode with connecting conveyors or tubes it simply didn't work (this was about three weeks ago).
     
  11. GotLag Senior Engineer

    Messages:
    1,114
    Kielm, do they work when you have set them to share with all?
     
  12. shimonu Apprentice Engineer

    Messages:
    396
    There was bug report about issue with assemblers not cooperating. Setting them as written earlier to share with all was workaround for it.
    I think I saw scripts that can help with it.
     
  13. AeonOfTime Trainee Engineer

    Messages:
    1
    I can confirm that the solution is to set them to share with all.

    I have two assemblers connected via the conveyor system (not directly adjacent to each other), and was able to set the second assembler to cooperate by setting both to share with all.
     
Thread Status:
This last post in this thread was made more than 31 days old.