Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

AsyncTCPSocket Created/Destroyed problem

Discussion in 'Groups & Dedicated Servers' started by cpy, Dec 28, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. cpy Trainee Engineer

    Messages:
    89
    I have this problem with AsyncTCPSocket Created/Destroyed problem on my DS. Friend can no longer join game. It used to work day before. Before that it didn't work, then few days before it worked.

    This is driving me mad! Why the hell is server working one day and other day does not? Anyone found way to fix this BS?

    Server is behind NAT on DMZ. So everyone mentioning port forward will be put to my ignore list to save time on reading posts from trolls.
     
  2. Ghostickles Senior Engineer

    Messages:
    2,074
    Makes no sense at all why this shouldn't work if it just was.
    Has your ISP made any (sudden, unannounced) changes that made things not be correct in router config now? Two years ago my ISP made changes which gave me a brand new IP, huge mess until I realized the change.
    Its a guess, but if you didn't change things, KEEN didn't change things, Valve (that I can find, still may be) didn't change things - maybe ISP did? Long shot, sorry, but as you said it worked before yesterday.
     
  3. cpy Trainee Engineer

    Messages:
    89
    This is most mindfuck problem I have. I run web server without problem, mumble runs 100% reliably. Life is feudal, 7 days, minecraft server etc etc. Only games that cause problems are space and medieval engineers and it drives me insane. When I ping friend that can't connect I get TTL expired in transit and traceroute does complete bullshit like it was 1 hop away without any routers.

    Funny part is that I get same error from 3 other providers in my country that I can test. But yesterday only my ISP showed this messed up route. It's like nationwide routing is fucked just for medieval/space engineers. It must be really hacky way that they did their.
     
  4. Ljorius Trainee Engineer

    Messages:
    61
    i have encountered this issue also some times. the problem seems to come from the isp itself or the isps service. one user had this error in the moment he tried to connect via mobile internet connection and the signal was jumping from one station to another / the signal was week or poor quality.
     
Thread Status:
This last post in this thread was made more than 31 days old.