1. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

Dedi Server Steam Login Failure

Discussion in 'Groups & Dedicated Servers' started by RumSpringaHQ, Jun 19, 2020.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. RumSpringaHQ

    RumSpringaHQ Trainee Engineer

    Messages:
    1
    Not sure what better place to ask for help on this but I'm trying to login so I can get the mod's going on the server but when I click on Steam -> Login literally nothing happens.

    It'll press the menu strip button, go away and then nothing else happens. Is there something I can verify besides steamcmd to make sure I have the required runtimes and server files?

    .NET 4.6.1 and later is installed, Visual c++ 2013. 2015 to 2019 is installed on the server.
     
  2. Roxette

    Roxette Senior Engineer

    Messages:
    1,546
    I've never even noticed that option, I've always just entered the mod ID numbers into the 'add mod' box, but I just tried it and it works fine, I suppose if you want to add a ton of mods and you're already subscribed to them it's a little easier :) - once it's logged in the subscribed logs show up in the list.

    Oh... it seems that it will only be able to login if you have an existing login session from a steam client on the same machine when you start it.

    Anyway, look at the logfile, normally in C:\ProgramData\SpaceEngineersDedicated\<server instance name> as SpaceEngineersDSGUI_<timestamp>.log
    that should help you debug the problem, if there is one at all.
     
    Last edited: Jun 19, 2020
Thread Status:
This last post in this thread was made more than 31 days old.