1. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

Ejectors filling up but not ejecting

Discussion in 'General' started by Kevin Langevin, Aug 3, 2020.

  1. Kevin Langevin

    Kevin Langevin Trainee Engineer

    Messages:
    1
    I've built several mining ships in SE, usually with a conveyor system that includes at least one sorter with stone (sometimes ice) whitelisted and Drain All set to on, and an ejector attached to that, with Collect All selected on. The past couple of days, my ejectors aren't ejecting anything. They just fill with whatever is whitelisted by the sorter, and don't eject anything at all.

    I seem to recall that the ejectors used to have a "Throw Out" setting, which isn't there anymore, and I'm trying to figure out when that disappeared and if it correlates to this problem starting.

    Are there any known issues with ejectors at the moment? I've verified that my sorters are pointed the correct way, stone and ice are getting through them into the ejectors (the ejectors are only connected to the sorters) and everything has plenty of power, they're turned on...I'm doing things the same way that I have on other ships in the past when they worked as expected. I don't think I'm missing anything in the process.

    Any help would be appreciated.
     
  2. mojomann71

    mojomann71 Senior Engineer

    Messages:
    2,005
    Single player or are you in Multi-player on a server?

    As far as I know there are no issues with the ejectors.
     
    • Agree Agree x 1
  3. NSI-Gromit

    NSI-Gromit Trainee Engineer

    Messages:
    9
    Hi, I have no issues with my ejectors neither and the "Throw Out" option is still there (single player too). This could be a conflict with a mod. Did you add one recently ?
     
  4. Spaceman Spiff

    Spaceman Spiff Senior Engineer

    Messages:
    2,026
    I just did a huge amount of mining and my small-grid ejectors ejected without failure. I had rock balls everywhere!
     
  5. SirConnery

    SirConnery Apprentice Engineer

    Messages:
    302
    Make sure you're not selecting multiple different items in control panel. The "Throw out" option should be there.
     
  6. Ronin1973

    Ronin1973 Master Engineer

    Messages:
    4,964
    If you replace an ejector block with something else in the same physical space on the grid... double check and make sure that the new block hasn't been added to your block list in that GROUP. Sometimes that happens. If you are ejecting stuff (like stone) and the ejectors are blocked, they might stop ejecting.
     
  7. Spaceman Spiff

    Spaceman Spiff Senior Engineer

    Messages:
    2,026
    I've had this happen numerous times with my space miners ejecting out the back; if you're not moving forward, they stop ejecting.