Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[HOW TO] Force ME to use a graphic card over another.

Discussion in 'Technical Help' started by DarkGhost, Feb 19, 2015.

Thread Status:
Not open for further replies.
This last post in this thread was made more than 31 days old.
  1. DarkGhost Junior Engineer

    Messages:
    765
    EDIT: If you are able to start Medieval Engineers but it is simply using the wrong GPU, you can change GPUs in Options > Display. Set the GPU you want to use, click ok, then restart the game.

    If you are having issues starting Medieval Engineers (crashing) and are sure your graphic card supports Directx 11, here are a few steps to do to force the game to use the NVidia/AMD graphic card instead of the Intel integrated (not-so) graphic card.

    ALWAYS RUN THE .EXE OF MEDIEVAL ENGINEERS AS ADMINISTRATOR.
    Users reported that not doing so may make it crash for some odd reasons.

    Steps for NVidia :

    - Go to NVidia Control Panel
    - Go to the Application menu (3rd one on the left, after the 3D and anti-aliasing menus)
    - Select Medieval Engineers in the drop down menu.
    - If it doesn't appear in the list, browse your files and go to /steam/steamapps/Medieval Engineers/bin (for 32-bits Windows) or /steam/steamapps/Medieval Engineers/bin64 (for 64-bits Windows) and select MedievalEngineers.exe
    - In the second drop-down menu, select the NVidia Graphic card (Second choice)
    - Press ok
    - Launch ME.

    Steps for AMD :
    - Exactly the same, except it's AMD Catalyst instead of NVidia Control Panel. Both panels are alike, except their name.

    Steps for Intel HD (Posted by Schmopster) :

    http://forums.keenswh.com/post/show_single_post?pid=1286277658&postcount=23

    If it still doesn't start, please do a new thread with your specs and the logs.
     
    Last edited by a moderator: Apr 26, 2018
  2. DarkGhost Junior Engineer

    Messages:
    765
    A little bump for people having the same problem with desktops.
     
  3. Bobaninja Trainee Engineer

    Messages:
    4
    Hello, Dark Ghost
    My problem is there is not second drop down menu to select the better graphics card.
     
  4. DarkGhost Junior Engineer

    Messages:
    765
    Only actually appears if you have 2 different graphic cards (The motherboard integrated one and the dedicated one, for example).
    If you don't, there is no point in changing it nor showing it.
     
  5. DarkGhost Junior Engineer

    Messages:
    765
    Steps for Intel HD added, thanks to Schmopster for those.
     
  6. Mishka Junior Engineer

    Messages:
    862
    Stickying
     
  7. torskee Trainee Engineer

    Messages:
    4
    Hi,

    Don't know if that is the case, but from what I've gathered here on forums and few other places, the reason that some of us (including me) can't play ME on nVidia with DX11, is that nVidia used "Kepler" GPU that do not fully support DX11.1.

    More:
    http://www.brightsidenetwork.com/news/2012/11/21/nvidia-doesnt-fully-support-directx-111-with-kepler-gpus2c-bute280a6.aspx

    If that truly is the case - then Keen should either adjust sys. requirements to include graphic cards with DX11.1, or downgrade those requirements to DX11.0

    Cheers
     
  8. King Richard Trainee Engineer

    Messages:
    1
    Hi I am using Parallels 10 on my Mac to run Windows and whenever ME starts up it says that my graphics card doesn't meet the requirements, but I have the NVidia Geforce GTX 960 with 4 gb vram. In Parallels the application I have all of the video, memory, and hard drive settings at the required specs for ME
    I looked at your solution but I can't get the NVidia Control Panel :(
    I would really like to play Medieval Engineers on my Mac
    I hope you can help
    Thanks
     
  9. DarkGhost Junior Engineer

    Messages:
    765
    Report it in a new thread as it's more related to using a VM program to play SE than forcing it to use the proper GPU.
     
Thread Status:
Not open for further replies.
This last post in this thread was made more than 31 days old.