Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

No Deers spawning

Discussion in 'Multiplayer' started by Natohk, Dec 6, 2018 at 20:29.

  1. Natohk Trainee Engineer

    Messages:
    8
    Hey everybody, i have a strange problem on my rented dedicated server. I modified the config and disabled the barbarians but the number for max KI is still 20. I thought then the deers would still spawn and no barbarians because i disabled the checkbox for them...
    But now.. nothing spawns. No barbarians and .. no deers.. is that a bug? Had someone ever had a similar problem?

    Thanks in advance
     
  2. CptTwinkie ME Asst. Producer Staff

    Messages:
    4,396
    Don't know what max KI is. The value you want it <MaximumBots>
    You may also want to note that if you just disabled barbarians that doesn't kill the existing ones and they take slots in MaximumBots. So kill the barbarians and the deer will spawn.
    Also, some places (tundra, one of the polar regions) don't really spawn deer. They can sort of wonder in but they are rare there.

    This question gets asked about once a week across our collective web presence. I'm surprised you haven't found another post about it already.
     
  3. Natohk Trainee Engineer

    Messages:
    8
    Hey CptTwinkie and many thanks for your answer. I checked with the admin tool.. and didnt found any barbarians and no deers.. no NPCs spawning since i disabled the barbarians.. and yes of course i meant MaximumBots.. that setting is on 20.
     
  4. CptTwinkie ME Asst. Producer Staff

    Messages:
    4,396
    you can try traveling to the forest and standing around for a few minutes before checking the deer again. either that or i can spend a lot of time loading source code for the public release and compiling a debug copy so that i can connect to your game to check that it is trying to spawn deer. since there is no way to disable deer at this point without modding them out of the game, it's highly unlikely you managed to stop them from spawning entirely. there is a small possibility that you have found some bug but we've never found anyone who could reproduce the problem. when we get a copy of worlds where this is reported we always load it, spawn in, and find deer.

    So if there is a bug, my only guess is that you are starting in some kind of dead area where deer can't spawn and when you travel out of it the spawning is stuck. When we start the world and spawn somewhere else, then the deer spawn. So try moving somewhere else (the forest again) and make sure the world gets saved with you there. Then restart and load in again.
     
  5. Natohk Trainee Engineer

    Messages:
    8
    Okay, thank you for your advise. I will follow your instructions and report back soon.