1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

No Loot Crates

Discussion in 'Bug Reports' started by r4y7ru7h, Sep 15, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. r4y7ru7h

    r4y7ru7h Trainee Engineer

    Messages:
    16
    It is a couple of updates that i lost my loot crates, i was used to spot them around every now and then (so, yes, my option is checked) but the green marker "Unknown Signal" does not appear anymore. i guess i can say i still perceive a little lag spike every 5 minutes, like the little lag spike perceived when my world spawned the loot crates, but no marker around at all anymore. It is a little thing but I'm not playing just because of this. i perceive other issues like the ships not keeping the "O" option of the antenna (lol, sometimes, while mining i go outside to check the asteroid and i dont find my ship anymore, even if i designed it to substain a 5000m antenna), but i could wait to this minor things to fix "by themselves". The loot crate thing is frustrating, because to achieve a full set will require a lot of crates, and a lot of crates means a loooooooooooot of time, time i'm already spending in game to do my things.
    thanks and BTW...Awesome game!!
     
    Last edited: Sep 21, 2017
  2. Tylus

    Tylus Apprentice Engineer

    Messages:
    427
    Hi,

    I have or had the same Issue on our Multiplayer no Crates for me in days. Havent checked today if they returned.

    Buut I noticed problems in signle player as well. I reset my configuration with an older state of it that I put into my version control. (I made changes to graphics and texture quality and stuff.

    In single player I got a new signal today. Hopefully it will also work on multiplayer again.
     
  3. darth_crunchus

    darth_crunchus Apprentice Engineer

    Messages:
    239
    I have noticed, that, at least with single player worlds, and I don't know if this has more to do with KEEN or Valve, that if you attempt to claim a loot crate that has no timer (e.g.: one that was active when you exited the world, and still exists when you reload that world), all crate spawns cease. I cannot, however, confirm if this is still the case if you do not save after having activated one of these crates.

    The reason I mention Valve in this is that I have a sneaking suspicion that activating a crate without a timer flags your current world as having either "cheated" in crates, or attempted to cheat. Leaving those crates alone, and letting them de-spawn when a new one pops in seems to be the safest course of action.

    Try starting a new world and see if you get crates there. If you do, you'll have to migrate your progress to a new world to continue with crates. If not, well, then you definitely have a problem. :(
     
  4. maverickwoe

    maverickwoe Trainee Engineer

    Messages:
    15
    Hi
    It's been a very long time (several weeks) that I haven't seen any crate again in the game.
    I tried on a dedicated server or local survival and with different worlds. Is there anything I could do to make them spawn again ?
     
  5. r4y7ru7h

    r4y7ru7h Trainee Engineer

    Messages:
    16
    @darth_crunchus I tried a new world and after 15 minutes more or les an unkown signal appeared. I tried my regular world hoping was fixed, but it is not, no signals there. how does the progress migration works? i dont really wanna lose my world...
     
  6. I23I7

    I23I7 ME Tester

    Messages:
    3,827
    Send me the world. If I can confirm it that when save corrupted like that we should e able to issue out a hotfix but i am not sure. Upload it to steam and send it to me please via PM
     
  7. jandraelune

    jandraelune Apprentice Engineer

    Messages:
    218
    The issue of no crates spawning is directly linked to logging off in a Crychamber. If your char has been in one for at least 24 hrs, when you come back you will have no creates spawn.
     
    • Like Like x 1
    • Disagree Disagree x 1
  8. r4y7ru7h

    r4y7ru7h Trainee Engineer

    Messages:
    16
    I play solo, so i never used cryochambers
    thanks 12317 i try to do what you said
     
  9. I23I7

    I23I7 ME Tester

    Messages:
    3,827
    Hey,

    Does not seem to be related to logging off in cryo chamber just tried that out and got a signal to spawn just fine. Was able to reproduce this issue.

    Thanks!

    Newsflash:

    Anyone having this issue please try this :

    Hey are you able to go inside your save and open your sandbox.sbc folder you should be able to find the first one and change it to the second one. Tell me if it fixes the problem for you please :


    <PlayerContainerData>
    <PlayerId>144115188075855897</PlayerId>
    <Timer>503</Timer>
    <Active>false</Active>
    <Competetive>false</Competetive>
    <ContainerId>0</ContainerId>
    </PlayerContainerData>

    to this

    <PlayerContainerData>
    <PlayerId>144115188075855897</PlayerId>
    <Timer>503</Timer>
    <Active>true</Active>
    <Competetive>false</Competetive>
    <ContainerId>0</ContainerId>
    </PlayerContainerData>


    obviously your player ID will be your steam player ID so change that one accordingly
     
    Last edited: Sep 22, 2017
    • Like Like x 1
  10. jandraelune

    jandraelune Apprentice Engineer

    Messages:
    218
    The issue I have ran into with Cyrochamber is on a Dedicated server. Will have to ask the server admin to check the file.
     
  11. r4y7ru7h

    r4y7ru7h Trainee Engineer

    Messages:
    16
    thanks 12317, your solution worked for me
     
  12. jemccro

    jemccro Apprentice Engineer

    Messages:
    101
    This did not work for me. I have also tried another player's fix by copying a crate before pressing the button in a world where they do spawn and pasting it into my world where they do not spawn.
     
  13. I23I7

    I23I7 ME Tester

    Messages:
    3,827
    Then send me your save file and i will check.
     
  14. The Chuggernaut

    The Chuggernaut Trainee Engineer

    Messages:
    22
    I am still having issues with the crates not spawning. When I look at the world settings, the Enable Unknown Settings box is blacked out and I cannot activate it. I looked for the segment of code in the sandbox.sbc file, and was unable to find it at all. I revalidated the files in Steam, and tried again, but it still does not work. I am on 1.184.5
     
  15. I23I7

    I23I7 ME Tester

    Messages:
    3,827
    Are you on creative or survival.
     
  16. The Chuggernaut

    The Chuggernaut Trainee Engineer

    Messages:
    22
    I was on survival, and I've tried creative too. I think I'm back on creative at the moment.
    --- Automerge ---
    Okay weird, now that I'm back in survival, it's decided to work, lol. Problem solved, I guess. :)
     
  17. XenoCow

    XenoCow Trainee Engineer

    Messages:
    18
    Thanks for the solution, @I23I7, it worked like a charm.

    For other people viewing this thread: the .sbc file is compressed, you may need to first extract the contents with 7zip and then copy the edited file back into the compressed version.
     
Thread Status:
This last post in this thread was made more than 31 days old.