Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Removing Steam ID disables server altogether... please help! :)

Discussion in 'Multiplayer' started by FartyParty, Jul 3, 2020.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. FartyParty Trainee Engineer

    Messages:
    6
    I have a server that I set up with torch.
    From day 1, I have had the SpaceEngineers-Dedicated.cfg file reflect a steam 64 group id here:

    <OnlineMode>PUBLIC</OnlineMode>
    ....
    <GroupID>12345123451234512345</GroupID>
    <ServerName>Server Name Here </ServerName>

    The server works fine and allows anyone from that steeam group to log in.
    Recently we made a decision to go public with this server. So I read to simply remove the ID from the tag, as follows:

    <OnlineMode>PUBLIC</OnlineMode>
    ....
    <GroupID></GroupID>
    <ServerName>Server Name Here </ServerName>

    However when I remove the group ID and restart the server, it never shows up in the list of servers and when I attempt to direct connect, it says "server not responding". If I put the group ID back in and restart then it boots fine and lets everyone connect fine.

    Is there another tag that needs to be changed after removing the Group ID? The Online Mode tag is already set to public, so I'm not sure what else to do, to get this thing open to the public.
     
  2. Roxette Senior Engineer

    Messages:
    1,546
    It should be <GroupID>0</GroupID>
     
  3. FartyParty Trainee Engineer

    Messages:
    6
    this worked, thank you!
     
Thread Status:
This last post in this thread was made more than 31 days old.