Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Resolution changes itself.

Discussion in 'Bug Reports' started by Unopinionated, Apr 6, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Unopinionated Trainee Engineer

    Messages:
    4
    Hello

    My screen's native resolution is (3840x2160). Although I turn it down in video games, because it is very taxing on my system. Most games I change to (1920x1080). Space Engineers resets the games resolution back to (3840x2160) on every load.
    This can be annoying having to change my resolution settings every single time I load the game. Or if I forget. Then I am bombarded with warnings letting me know that the graphics are to high.

    Thank you.
     
  2. Zhiila Tester Staff

    Messages:
    487
    hi,

    that's strange. I've just tried it and it resolution was the same after restart of the game. I would try to change it in config file manually. Can you try to go to \Users\current_user\AppData\Roaming\SpaceEngineers\SpaceEngineers.cfg and change following lines accordingly to prefered resolution?

    Code:
    	  <Key>ScreenWidth</Key>
    	  <Value xsi:type="xsd:string">1920</Value>
    	</item>
    	<item>
    	  <Key>ScreenHeight</Key>
    	  <Value xsi:type="xsd:string">1080</Value>
    	</item>
     
  3. Unopinionated Trainee Engineer

    Messages:
    4
    Hello,

    Thanks for the reply. Whenever I check the CFG file. It shows 1920x1080. Although the game still defaults to the higher resolution. It might be worth pointing out that I install the game on my second hard drive. The CFG file and windows are on C:\ (SSD) while the game is installed on D:\ (HDD). All games are on the HDD due to the small size of the SSD. Would that be effecting it?
     
  4. Zhiila Tester Staff

    Messages:
    487
    It shouldn't be affecting it (I have it same way).

    Did you try to change Window mode in Options/Display? I would also probably try to rename SpaceEngineers folder in \AppData\Roaming\, so the game create new folder and new .cfg. Unfortunately I am not ale to test it because I don't have 4K monitor, I will ask around the office if someone has any other idea or is able to test it.
     
  5. Royale98 Trainee Engineer

    Messages:
    57
    I tested this myself to attempt to replicate, here is what I tried and the results:

    Testing methodologies: if you don't feel like reading individual tests and results, skip to below
    Total conclusive results: Incident was not able to be replicated by any performed tests.

    Suggestions:
    1. Verify game cache in Steam: Right click on game in steam library, select "Properties", go to "LOCAL FILES" tab, select "VERIFY INTEGRITY OF GAME FILES...", let it work its magic, test again (test after everything, and if something does fix it, let us all know :D ).
    2. Update your graphics card driver if not already on latest version (clean install, i.e. uninstalling current driver and installing fresh, would be best whether by selected option or by doing so manually).
    3. If you're already on the latest graphics driver: rollback to older version (clean install recommended again).
    4. If you're using NVIDIA hardware: Open NVIDIA control panel, click on "Manage 3D settings", click "Restore" to return to default settings.
    5. If you're using AMD hardware: I have no clue what AMD gives people, so you'll have to do your own research there.
    6. Try a different monitor or a friend's if you have one available or if they'll let you borrow one.
    7. Try a different GPU or a friend's " ".
    8. BELOW SUGGESTIONS ARE *NOT* RECOMMENDED BUT MENTIONED FOR YOUR INFORMATION
    9. As a last ditch effort, you could try wholly uninstalling and removing all Space Engineers files as well as any of those microsoft, DX, or runtime programs that often get downloaded when running a game for the first time, the annoying ones that you end up with 100 of because you installed a lot of games... then reinstall.
    10. And if you're desperate and crazy, wipe windows, and reinstall.
    PS: I might also recommend simply running in 4K and turning down a few graphical settings. I noticed that between 1080p and 4K there was only ~10fps difference (high 50's to 60 in 4K, mid 60's to mid 70's in 1080p, peak frame rate was 81 fps in 1080p). Though you're GPU and CPU will decide if that's okay or not, you know you're system better.
     
  6. Auhrii Apprentice Engineer

    Messages:
    274
    Also having this problem - native screen resolution is 3840x2160, game config file resolution is 1920x1080. Game seems to completely disregard the config file and starts at 3840x2160 every time.
     
  7. Scoot Trainee Engineer

    Messages:
    31
    i had the same issue on my old laptop when running at a resolution lower than my desktop resolution. desktop resolution might be a hint.
     
  8. mojomann71 Junior Engineer

    Messages:
    622
    @Scoot why for the love of Clang would you even try SE on a laptop?? :)
     
  9. Auhrii Apprentice Engineer

    Messages:
    274
    I run SE on a laptop - resolution issue aside, I get a constant 48fps (the monitor is hardware-capped at 48) and simspeed stays high so long as I don't do anything stupid.
     
  10. mojomann71 Junior Engineer

    Messages:
    622
    Not saying it couldn't be done, just to me seems like it would be a challenge. Keys so close together..etc :)
     
  11. Auhrii Apprentice Engineer

    Messages:
    274
    Ah, yeah. I do use a mechanical keyboard on top of my laptop's keyboard... though to be fair, that's mostly because I do a lot of programming. The overheating is an issue, though.
     
  12. Unopinionated Trainee Engineer

    Messages:
    4
    I play on an alienware laptop. This thing is a beast that can run most games perfectly. So why run it on a laptop? Because I get to be lazy on a couch or in bed. The 2 suggestions offered - (change desktop resolution, and Keep higher resolution and turn down graphic's) are both work-arounds, but not fixes. I would rather manually turn down the resolution in game every time, like I have been. Rather than change my desktop resolution before playing. If there is no fix yet, then I can live with that. But I feel the issue should be floated out there so a fix can one day arrive. It sounds like I am not the only one having this problem according to the others who posted in this thread.
     
    • Agree Agree x 1
Thread Status:
This last post in this thread was made more than 31 days old.