Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Sensors dont care about distance settings.

Discussion in 'Bug Reports' started by DemeterHUN, Oct 18, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. DemeterHUN Trainee Engineer

    Messages:
    9
    Hi there. I'm desperate to hear a word when will this bug fixed that sensors settings don't work. Set to detect asteroid. When everything is set to 1 m, it detects voxel from about 40 m. I really would love to have that fixed, please!
     
    Last edited: Oct 18, 2017
  2. Scya Apprentice Engineer

    Messages:
    266
    Do you have locked rotor or piston anywhere on your ship? It is causing problems with detectors range for me.
     
  3. DemeterHUN Trainee Engineer

    Messages:
    9
    Nope, no rotors, no pistons, no subgrids at all. I thought this is a known problem. Makes me impossible to make some automated miners. :(
    I'm talking about planet voxel tho.
     
    Last edited: Oct 19, 2017
  4. Sinbad Senior Engineer

    Messages:
    2,788
    planet voxels act strange with sensors. it seems they are generated in a big chunk including any empty space. the sensor detects the chunk, not the voxel surface. so sometimes even 10 or 20 meters up you can still detect a surface. if you dig into the detected entity info, it will give you a location near the middle of the chunk, but nowhere near where it should be.
    you can try it yourself:

    build a 3 high large grid pillar, put a rotor on the side of the top block, put a block on the rotor and a sensor on the block so that as the rotor spins the sensor will rotate between ground and sky. adjust your field for max range on the front and min range everywhere else. set it to only detect voxels. spin the rotor. note the sensor does not turn off when the field has cleared the ground. if you move the whole contraption to a few locations you may even be able to find a spot where the sensor will detect voxels while pointed at the sky.
     
  5. I23I7 ME Tester

    Messages:
    3,827
    Can try and turn on you sens range field in INFO in the control panel and then find the Sensor in the control panel and turn SHOW ON HUD it should show you what your sensor is detecting. Tell me if it behave wrong.
     
  6. DemeterHUN Trainee Engineer

    Messages:
    9
    Yes, it behaves wrong. I didn't need to do that to find out, however, i never realized to actually show the sensor range I have to turn the show on hud as well. Now I do, thanks! :) Could be the thing what Sinbad wrote. It is only with planet voxels.
     
  7. Artax Trainee Engineer

    Messages:
    30
    I have a hangar that uses sensors to open the doors when a friendly vehicle or person approaches the doors. When the ship locks landing gear to the hangar the sensors are triggered even when the ship is outside of sensor range. It only releases when the landing gear is unlocked.
     
    • Agree Agree x 1
  8. Thrak Junior Engineer

    Messages:
    535
    I’ve seen the same thing. It appears the sensor is using its max range 50m even if set lower.
     
Thread Status:
This last post in this thread was made more than 31 days old.