1. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

The Game Keeps Saying I don't have DX11 but I do

Discussion in 'Technical Help' started by minary, Jul 29, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. minary

    minary Trainee Engineer

    Messages:
    1
    I have been playing Space Engineers without any problems, and I decided to see if it works over RDP and RemoteFX (which provides DX11 over rdp session) but I forgot to enable some options, resulting in non-RemoteFX session. I turned on Space Engineers, and game naturally said "The current version required Dx11 card. If you would like to play blah blah blah blah" I noticed that I had non-RemoteFX session, so I quit it and came back to my desktop to play it.

    I logged in to my Windows account, logged-in to Steam, and clicked 'Play' button on Space Engineers. Then it would say that my computer don't have DX11 card. I tried deleting and installing the game, and latest development branch, and even as far as trying DX9 branch. Latest development branch said I don't have DX11 card. However, DX9 branch worked. I could even switch renderer to DX11 and it worked fine!

    EDIT : After using DX11 renderer in DX9 branch, main branch worked.

    --System Information--
    OS : Windows 10
    CPU : Intel Xeon E3 - 1231 v3
    RAM : 16GB
    GPU : AMD Radeon R9 200 Series
    Feature Levels: 11.1,11.0,10.1,10.0,9.3,9.2,9.1
    Driver Model: WDDM 2.0
    DDraw Status: Enabled
    D3D Status: Enabled
    AGP Status: Enabled
    I can provide full dxdiag if needed.
     
  2. Interstellar Pi

    Interstellar Pi Trainee Engineer

    Messages:
    1
    So i tried switching to dx11 while in the Dx9 32-bit capability branch but after i restart the game it has switched
     
Thread Status:
This last post in this thread was made more than 31 days old.