Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Workshop Thumbnail for IngameScripts (Broken?)

Discussion in 'General' started by Randy, Mar 10, 2019.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Randy Trainee Engineer

    Messages:
    3
    I cannot change the thumbnail of my ingame script.
    I tried everything:
    • Uploading without a thumb in the hope that steam would pick the first uploaded picture
    • Changing the tumb size (been from 50kb to 1Mb)
    • changing tumb resolution (256x256, 512x512, 1024x1024, 640x360)
    • Using a thumb generated by making a blueprint
    • Trying to use a .jpg instead of .png
    It works fine in Space Engineers, but steam will always show:
    [​IMG]

    [​IMG]

    Even the default blue C# thumbnail does not work..
    Anyone that found a fix for this?
     
    Last edited: Mar 10, 2019
  2. Roxette Senior Engineer

    Messages:
    1,499
    Yes, eventually.

    Because Keen have not implemented support for this in the game since the change to Steam workshop integration, you need to do it using the Steam command-line client.

    Download and install the console client from Steam: https://developer.valvesoftware.com/wiki/SteamCMD#Downloading_SteamCMD

    Create a Valve data file ( something.vdf ) with your favourite text editor following the format described here:

    https://partner.steamgames.com/doc/features/workshop/implementation?language=english#SteamCmd

    Point it at the directory containing the script.cs file or whatever other mod you want to update the data for, pointing the previewfile parameter to the image file. Note the double backslash characters in the paths. Settings that are not changed need not be included, so for example to just update the workshop preview on an item, the vdf would look like this:

    Code:
    "workshopitem"
    "appid" "244850"			 <<- Space Engineers Steam application ID #
    "publishedfileid" "829739135"		 <<- The mod ID as shown at the end of it's workshop URL
    "previewfile" "D:\\Content\\preview.jpg" <<- Pathname of image file
    

    Run steamcmd.exe in a command prompt window, log into Steam using your account credentials that match your ownership of the workshop mod you want to change. (If you have the Steam cliient running at the same time that will get logged out) Then issue the command:

    workshop_build_item something.vdf

    include the path to something.vdf if it is not in the SteamCMD directory.

    Job done. (This procedure can be used to set or change details of any of your mods)
     
    Last edited: Mar 20, 2019
    • Like Like x 3
    • Informative Informative x 1
  3. Randy Trainee Engineer

    Messages:
    3


    It worked like a charm, thank you very much! :)
    [​IMG]
     
    • Like Like x 1
  4. SHUK Trainee Engineer

    Messages:
    1
    Hello, I have got the same problem with updating my preview image, I have tried this way with steamcmd. Have created .vdf file and logged in steamcmd, but when I run "workshop_build_item something.vdf" i getting this error.

    Steam>workshop_build_item something.vdf

    Preparing update...
    Uploading preview image...ERROR! Failed to update workshop item (Limit exceeded).

    I thought its must be something with picture size, but I have tried all from 681kB down to 1.4kB and getting the same error. Any thoughts about what it can be?
     
Thread Status:
This last post in this thread was made more than 31 days old.