Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Workshop thumbnail size limits - Failure to Upload.

Discussion in 'Community Creations' started by Ronin1973, Dec 17, 2019.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Ronin1973 Master Engineer

    Messages:
    4,944
    Yesterday I couldn't get a ship to post in the Workshop. I tried everything short of reinstalling. The error message kept telling me to try logging in... granted. The Steam Overlay was up and I was definitely logged in.

    I searched and found a post from a dev about the maximum file size being 1.5mb.

    It's actually 1mb.

    If you're using a wide-screen display or a monitor with a high pixel count, your thumbnail might very well be over 1mb. I solved the problem by cropping my image to get it down to less than a megabyte.

    Granted the error message is extremely misleading and there aren't any safeguards in Space Engineers to make sure that your thumbnail is under the maximum allowed size. You have to go into your local blueprints, find the blueprint you want to upload, open the folder and then use something like MS Paint to handle the cropping.

    Perhaps this post will get pinned. But I'm leaving it here in community creations because this no doubt has happened to more than me and someone is pulling his/her hair out trying to figure this one out.

    Cheers.
     
  2. Stardriver907 Master Engineer

    Messages:
    3,368
    So THAT'S what's been happening! I thought Steam was cutting me off for uploading so many screenshots and worlds. All this time it was my &*#$&*^ thumbnail size?

    Man, it's alway something :mad:



    As long as I'm here, somewhere along the line I missed the memo about how to make a local blueprint directory that I had assumed the game would make for me. Any help in this area would be greatly appreciated.
     
  3. Roxette Senior Engineer

    Messages:
    1,539
    As usual, Keen added the feature in a jenky and incomplete way without any documentation or in-game help. You have to add blueprint directories manually e.g. by opening a Windows Explorer window* to %appdata%\SpaceEngineers\Blueprints\local\ and creating new directories there. If you want to re-organize existing blueprints into folders it is a lot easier to do it from the Windows Explorer than from within game, as the only way to do it in-game is with a bunch of copy/paste/delete actions, because making sane user interfaces is complicated and has little commercial value at this stage in the development cycle.

    *Obviously you can do it just as well and faster from a command prompt window, as I think your computer use, like my own, predates microcomputer graphical user interfaces ;)
     
    Last edited: Dec 18, 2019
    • Friendly Friendly x 1
  4. Stardriver907 Master Engineer

    Messages:
    3,368
    You know, a lot of times I think you come on a bit... harsh. This time though I must agree. There have been several hotfixes since the update and this was not one of them.

    Then, on top of that, Keen finally makes creating a blueprint and creating a thumbnail for it a single process... and the thumbnail is suddenly too big. Altogether this makes blueprinting your stuff kind of a challenge.

    At least my sessions still get saved.



    For now.
     
  5. Spaceman Spiff Senior Engineer

    Messages:
    1,959
    I figured all this out quite some time ago when several of my uploaded blueprints failed to upload. I didn't know the limit is 1MB...I've been intentionally trying to keep the thumbs under 800KB figuring the limit wasn't far above that.
     
Thread Status:
This last post in this thread was made more than 31 days old.