Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 1.184.3 Minor - Beta improvements

Discussion in 'Change Log' started by flexx, Oct 5, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. flexx SE Asst. Producer Staff

    Messages:
    197
    Hello, Engineers! This week's minor release comes with some important general improvements. Issues fixed include a number of audio issues like wheel sounds playing even when a vehicle is not moving and choking sounds being heard by all players. Also, the Doppler Effect should now be heard correctly through your sound device of choice. Additionally, there’s some modding improvements; mods can now use WAV format audio instead of WXM.

    Also, the game will now pause when you open the steam overlay, and will properly ignore keyboard input while the overlay is open.

    Behind the scenes, the team is busy working towards some exciting major updates for the game as we approach the fourth year anniversary of Space Engineers. Stay tuned...

    Fixes:
    • fixed crash when players were attempting to render and fast moving ship with respawn station
    • fixed crash when modifiying their save .sbc files and attempting to go into setting in-game
    • fixed crash when certain Mech blueprints being destroyed would cause crash
    • removed certain ships from random encounters that cause sim speed drop
    • changed the large tube component model size
    • fixed loading screen background not scaling properly for all resolutions
    • fixed ESC button being registered when entering the steam overlay
    • fixed hitbox on astronaut being larger than intended
    • fixed GPS staying after looting the body before changing to a backpack
    • fixed blocks staying selected on DS when entering cockpit
    • fixed doppler effect not working for audio
    • fixed odd behavior for audio of first gatling shot not respecting distance
    • fixed grinder sound playing after grinding down block
    • fixed choking sounds being heard by all players
    • fixed wheel sounds playing despite the vehicle not moving
    • fixed audio files not being located for modded blocks
    Regarding decreased sim speed when using tools: This problem was already in the game for some time but was not visible due to other things. We are working hard on a fix but due to the difficulty of it we would like to ask players to be patient as the issue will be solved in the next Major update.
     
    • Like Like x 12
    • Informative Informative x 2
  2. Ed Frost Senior Engineer

    Messages:
    1,133
  3. Forcedminer Senior Engineer

    Messages:
    2,202
    yes more fixes to rover wheels making sounds while not moving! ^^
    I love me some half baked ugly but funtional rover.
    .
    mods can now use WAV format audio instead of WXM.
    REALLY?! woah that'll save me having to use a skyrim modding tool to convert it! :p
    +happiness +time needed to make sound block mods!
    https://www.nexusmods.com/skyrim/mods/8303/?
    .
    choking sounds being heard by all players
    I have heard of that by other players but haven't experienced it.
    .
    that seems very useful.
     
    Last edited: Oct 5, 2017
  4. Phoenix84 Junior Engineer

    Messages:
    983
    I miss xocliw. :-(

    Did you also fix the TAB key?
     
    • Like Like x 1
  5. Cassius Faux Apprentice Engineer

    Messages:
    175
    Fixes are always welcome. I do hope videos resume soon, they were nice.
     
    • Agree Agree x 2
  6. gornyakmaniac Apprentice Engineer

    Messages:
    186
    I thought you fixed that sound in previous update, or not?
     
    • Funny Funny x 2
  7. Super_Happy_Alien Apprentice Engineer

    Messages:
    386
    • removed certain ships from random encounters that cause sim speed drop
    What ships where removed ?
     
    • Like Like x 1
    • Agree Agree x 1
  8. Silvrav Trainee Engineer

    Messages:
    41
    Regarding decreased sim speed when using tools: This problem was already in the game for some time but was not visible due to other things. We are working hard on a fix but due to the difficulty of it we would like to ask players to be patient as the issue will be solved in the next Major update.

    Good as this is causing servers to crash
     
  9. Foogs Apprentice Engineer

    Messages:
    123
    :stare:bad.
     
    • Disagree Disagree x 3
    • Agree Agree x 2
  10. Carlosmaid Apprentice Engineer

    Messages:
    174
    • removed certain ships from random encounters that cause sim speed drop

      This caught my attention, what makes those grids especially cause simspeed drop? Should not the root problem be solved? and not just removing those grids
    --- Automerge ---
    And i miss xocliw videos too.. :(
     
  11. Forcedminer Senior Engineer

    Messages:
    2,202

    if i had to guess maybe the programmable blocks that gives them their low level AI has something to do with it.
    I've a feeling it might be the most biggest and most impressive ships for now might be gone. :(
    hope its not the mighty "Argentavis"
    [​IMG]
     
    • Agree Agree x 1
  12. AlfieUK4 Trainee Engineer

    Messages:
    48
    From looking in the SpawnGroups file, It appears to be only;

    Armed Transport Charon (a note says it explodes on spawn)
    The Pilgrim's Curiosity (no note, but probably to do with the intrusion detection system it employed)
     
  13. Carlosmaid Apprentice Engineer

    Messages:
    174
    And i miss xocliw videos too.. :(
    keen pp explained me in discord that is because pistons. Ship was exploding when spawn.
     
    • Agree Agree x 1
  14. viper312005 Trainee Engineer

    Messages:
    90
    Yup those are what i saw...i removed the argentavis cuz of the wonky ai on it
     
  15. halipatsui Senior Engineer

    Messages:
    1,247
    Certain mech blueprints causing crash?
     
  16. krypt-lynx Apprentice Engineer

    Messages:
    174
    • Friendly Friendly x 2
    • Like Like x 1
    • Informative Informative x 1
  17. KingdomBragg Junior Engineer

    Messages:
    544
    Thanks for the fixes
     
  18. xiojade Trainee Engineer

    Messages:
    82
    Ditto! And thanks a lot for the heads up about the sim speed problems, I hope it's not too much trouble to get ironed out ^^
     
  19. Stardriver907 Senior Engineer

    Messages:
    2,188
    I can imagine there are several problems like this in Space Engineers. Imagine them peeling back the layers of problems until they are able to put the ladder climbing animation back in 0_0
     
    • Funny Funny x 2
  20. Thrak Apprentice Engineer

    Messages:
    373
    Yeah, what the heck does this mean? Is it a fix for the projectors bugs currently plaguing the game, or something else?

    Fixes are always welcome, of course. Clarity even more so.
     
    • Agree Agree x 1
  21. woodzykiler2 Trainee Engineer

    Messages:
    19
    The tools issue causes a Desync issue. also, can you all add a "if you ping is over a sertin amout you get auto kicked". i have people join with pings over 200ms and it causes the sim speed to just drop hard... Well back to crashing servers one at a time. but it doesnt seem to happen to everyone ro every server. LIke THE ONE THING USED TO PLAY THE GAME is the worse bug.... and it still hasnt been fixed why? can i get a refund?
     
    Last edited: Oct 5, 2017
  22. FoolishOwl Apprentice Engineer

    Messages:
    413
    I'm hoping that will include some of the more popular and reasonable feedback suggestions.
     
  23. quarior14 Trainee Engineer

    Messages:
    33
    Oh, I patient.
    Also I don’t know if the problem from Steam or Space Engineers but for this moment is the single game have this problem. :
    I have many workshop subscribers (I download (mods and blueprints by example)) and when I edit settings’s world for edit mod list of a world and when I open blueprint list, I disconnect of Steam and the loading of mod list and blueprint list of workshop don’t load or there are loading but when I disconnect, I disconnect from the « server » (or other players of the game are show for me « players disconnect ») and defois the only way to fix is restart the game or Steam.
    Anyone have this or a problem similar ?
     
  24. darth_crunchus Apprentice Engineer

    Messages:
    239
    Indeed. What ships did y'all get rid of?
     
  25. Devon_v Senior Engineer

    Messages:
    1,602
    From my experience with the EEM, it's ships with complex conveyor networks. But that may not be what they're referring to here.
     
  26. BlackTulip06 Trainee Engineer

    Messages:
    1
    Hi, I think this is an issue with light round armor in symmetry mode, the round armor just can't get mirrored correctly. I and my friend have already had this issue for 3 weeks. I tried to remove all mods from a world and reinstall the game, but I still can't solve the problem.
     
  27. Ronin1973 Master Engineer

    Messages:
    4,339
    There seems to be a video on the major updates. I'm cool with that if the time saved goes into more inclusive list of optimizations and bug fixes. The more things listed, the more feedback on how well those changes were made.
    --- Automerge ---
    Edit.

    How about including the ships removed by name? There had to be a kill-list somewhere at Keen. Copy/paste?
     
    • Agree Agree x 1
  28. AlfieUK4 Trainee Engineer

    Messages:
    48
    I posted this already (#12) but the removed ships (commented out in SpawnGroups) are;

    Armed Transport Charon
    The Pilgrim's Curiosity
     
    • Informative Informative x 1
  29. Byzod Trainee Engineer

    Messages:
    54
    This game breaking bug is still not fixed :/
     
    • Agree Agree x 1
  30. darth_crunchus Apprentice Engineer

    Messages:
    239
    How many grids do you have in your game, and are you on a server?
     
Thread Status:
This last post in this thread was made more than 31 days old.